Thermometer App crash


  • Greetings,

    in case you have issues with the thermometer app. I tracked a issue down to it's core.

    If you change the phone language to anything else then Eng. (in my case German), the app will still start - but if you press "messure" it crashes. When the language get set back to englisch, the temperature app is working again. 

    My best guess is, that there is somewhere a missing lingualisation that cause the crash.

    Hope it helps.



  • @Bartosz Prill Good day, thank you for your feedback. Our R&D has already dealt with the problem expeditiously. Now it has been certified by Google. It is expected to be approved next week. A new version will be released. Good wishes!


  • Dears,

    Today, 30/09/2021, Thermometer app is still defective, it only works in the English language, another language continues to give an error (in my case, Portugues, Brazil). I await a solution.


  • @WEMERSON NASCIMENTOGood day, I am sorry to hear this bad news. In Russia, we have solved the problem of thermometer error and released it. We are now accepting Google certification for EU and non-EU versions. You can update the version next week. This problem can be solved by GOTA upgrade at that time. best wishes!


  • Someone knows how to calibrate V10 thermometer sensor? Or even restore factory data calibration?


  • @Leonardo Ferreira "- Should the app say "missing calibration data" -> then use SP Flash tool to flash from your backup "ROM_34" to "proinfo" (Should you have fucked up and skipped the backup part.. well.. perhaps somebody else may provide it to you... ask nicely in the forum and I may upload it aswell)" Source: Pre-rooted Doogee V10 | Doogeeofficial (doogeemall.com)


  • https://easyupload.io/y6kxea <-- ROM_34. Link is valid for 30 days. Will reupload if needed.


  • @Bartosz Prill Thank you a lot for your reply, I could find your ROM_34, but I think it is not a good moment to play with this flash tool and brick the Phone, it is so new to be bricked by another mistake.

    The problem was this fucking factory Mode that reset the calibration when you try to test the thermometer feature.

    Doogee should remove the Thermometer Adds from his page, as I couldn`t imagine any regular user using an SP flash tool to make some telephone feature get working. kkkkkk


  • @Leonardo Ferreira Good day, the machines shipped by our V10 are all calibrated, did you click the reset button?


  • Ofc you should not flash anything, without have at least some kind of experiance or know what you are doing. The ROM_34 meanwhile is just a backup of the partition where the calibration data are were stored before a factory reset\system wipe.

    So by flashing this ROM_34 with SP Flash Tool over the "proinfo" partition there should no harm be done to the phone (just make sure you deselect all the other checkboxes, so you don't flash anything else by accident)

    This is just so far the fastes method "I" found so far to restore the functionality of the thermometer app. However I don't claim it is the only nor the best one ^^ Just the one "I used" and share with the community. Happy to learn if there are easier or better ways however


  • This is a very well-written and informative post. In my opinion, this is one of the very best posts that has ever been published. Your work is outstanding, and it motivates me to do better. I am grateful that you uploaded this content. I am a test user for gaming websites in order to ensure that those gaming websites are secure. In the course of my testing, I came across a game that is popular among students and is perfectly safe for everyone to play. The entertaining game. The Lol Beans has cute and expressive snake characters. Because of its widespread appeal, players of all ages and genders can be found participating in this game.


Please login to reply this topic!