Pre-rooted Doogee V10


  • Hi Folks,

    I will soon upload a Pre-rooted FW of the Doogee V10 with Guide about how to use it.

    However here one important notice! Keep in mind that you void your warranty by unlocking the bootloader and rooting your phone! Unlocking the phone is only making sense, if you need the root for particular tasks!

    I take no responsibility aswell for bricked devices. This is just a guide how "I" made it.

    So - do it on your own risk!

    Link and Guide will come soon - just want to make sure first that everything works fine and that there are no issues with the pack before.

    Best Regards



  • We do not recommend customers to rooting the mobile phone. Rooting the mobile phone may cause unpredictable parameter disorder and make it impossible to use normally, and may cause the mobile phone to no longer be in the warranty range. Please pay attention.


  • Sorry for the long waitingtime. I tried to make OTA work. But currently I still haven't made it. 
    But I want to share with you now the steps how to install magisk on the Doogee V10.

    However I decided to skip the pre-rooted firmware for now, since there are a couple of possible issues that may cause permanent damage, if not applied correctly.
    So I skipped it for now.

    Now before we start - first of all:

    WARNING: 

    - I take no responsibility for bricked devices. 
    - Keep in mind that rooting WILL VOID your warranty!
    - Only root your device if you really need to!
    - And most important... MAKE A FULL ROM BACKUP FIRST!

    HINT:

    !!!ALL YOUR DATA ON THE PHONE WILL BE DELETED IN THE PROCESS!!!

    Backup: 
    For making a Backup use the "MediaTek SP Flash Tool" in the latest version. (At time of writing this is v5.2112.00)

    To make a Backup edit the option.ini of SP Flash Tool and change: "ShowByScatter=false" --> "ShowByScatter=true"

    Get Latest Stock ROM of V10:
    (Current at time of writing) https://1drv.ms/f/s!AvX9KABcpSV1lVBk1V-eF7dlSM4h --> EEA --> 2021-08-19 v100a-dg-m18-mt33-l-1024g48g-hdp-DOOGEE-V10-11.0-20210817_R21_20210818多国语量产软件.zip

    Unzip the Stock rom in a empty folder and navigate to "R21-bom1-20210817_user_20210818"
    In  this Folder you see a bunch of *.img files that is used by SP Flash tool for making a firmware upgrade.

    In "SP Flash Tool" press on "Scatter-loading File" on "choose" and navigate to the folder of "R21-bom1-20210817_user_20210818" and select there the "MT6833_Android_scatter.txt"
    Then switch to "Readback"-Tab.

    You should see now a list of partition names.
    Check the checkbox next to "partition name" to select all of them and press "Read Back" - and then connect your phone to the PC with a USB cable and restart the phone.

    Then the phone should start to backup the partitions and write them in the "SP Flash Tool" root directory and generate 52x Files (ROM_0 --> ROM_52)

    Now copy those files somewhere safe and copy from the Stock Rom directory the scatterfile (MT6833_Android_scatter.txt) inside it aswell.
    Open the copy of the "MT6833_Android_scatter.txt" and now make the following change:

    Replace all: "is_download: false" --> "is_download: true"
    And replace all: "file_name: <WHATEVER NAME IT WAS>" --> "file_name: ROM_<WHATEVER NUMBER IS IN PARTITION INDEX>"
    So as a example: "file_name: preloader_k6833v1_64.bin" --> "file_name: ROM_0"
    At entries like SYS1 where there is "file_name: NONE" use the same method and turn it into "file_name: ROM_1".
    We do this, so we have a matching scatter file for our restore later in case something went wrong.

    PLEASE DON'T SKIP THE ABOVE BACKUP STEP! You will regret it!

    After having a Full Backup of our Phone - one word of warning in regards of the "SP Flash Tool"
    You may have seen that there are options for "Format All +Download" under in "Download" tab and that there is a entire "Format" Tab for manual or automatic format.
    DON'T TOUCH THIS!

    With doing this format, you will lose your Serialnumber, IMEI and a lot of other things that CAN'T BE RESTORED (... if you don't have a Full backup!) And even with a full backup you will get a odd error later that can't get fixed anymore (with red written google and tee text on the upper right screen). You can fix this too, but it's unnecessary struggle. So just take my advice and forget that this function even exists!

    Now the fun part...

    Starting the rooting process:
    In your phone go to "Settings -> About Phone" and tab a few times on "Build umber" until you are getting the display "no need, you are already a developer"
    Then go back and go to "System -> Advanced -> Developer options" and enable the options "OEM unlocking" and USB debugging.

    Then go to https://github.com/topjohnwu/Magisk on your phone and download the latest Magisk apk (currently: Magisk-v23.0.apk) and install it.
    After that connect your phone to the pc, confirm that the pc is allowed to connect to the phone, and move the "boot.img" from the stock folder (R21-bom1-20210817_user_20210818) to the phone internal storage.

    Next open Magisk on your phone and choose "Install" next to Magisk (not app). Then browse to the stock "boot.img" on your phone. And press "Let's do it" and wait for the patching process to finish.
    After that go on your pc to the download folder inside your phone - there should be a "magisk_patched-XXXXX_XXXXX.img" file. 
    Copy it to the pc and put it in the directory of your "minimal adb fastboot" shell.

    After that restart your phone and press the button "VOL+" on your phone until you get a list of 3 menu points called "recovery, fastboot, normal".
    By pressing "Vol+" again you can choose between the menu points, with "Vol-" you select the point.
    Choose "fastboot" with "Vol+" button and "Vol-" to confirm it.

    "Fastboot..." should be now written on your mobile phone screen below the menu.

    Next you need to install ADB and Fastboot on your PC. I recommend to use a "minimal adb fastboot installer" for getting this step done and install the SP drivers from https://1drv.ms/f/s!AvX9KABcpSV1lVBk1V-eF7dlSM4h (Driver_Auto_Installer_EXE_v5.1632.00.zip) - unzip them and install them with "DriverInstall.exe"

    Then start the fastboot shell (minimal adb fastboot) and type "fastboot flashing unlock". (HINT: CONFIRMING THIS WILL WIPE YOUR USERDATA!!! NO CHANCE TO TURN BACK AFTER PRESSING "YES" HERE)
    After that there will a prompt be on your phone to confirm unlocking the bootloader. You can confirm it by pressing "Vol+"
    Next you will need to install a modified vbmeta.img
    You can get one from here: https://mega.nz/file/dnAS3AhD#g5PnSg-0UKFvyhZSZ8Em6gKO2Do7avaUepPmsH75-Bg
    You can flash it with the command: "fastboot flash vbmeta vbmeta.img"
    (perhaps you need to move the file from your download first into the directory, you are in on the fastboot shell cmd on your pc)

    Next comes the tricky part!

    DON'T FLASH THE "magisk_patched-XXXXX_XXXXX.img" here now, how you normaly would do it!!!

    Instead type "fastboot reboot fastboot" !!!
    Your phone will restart now and get into a different instance of fastboot (called fastbootd) and HERE you can now type on your pc in the fastboot shell "fastboot flash boot magisk_patched-XXXXX_XXXXX.img"
    And afterwards "fastboot -w" which will wipe your entire userdata on that moment - but this step is neccesary, since else the encryption won't work properly. (and besides... by unlocking the bootloader there is anyway no data left...)

    Next type "fastboot reboot" and pray ... When you did everything correct, the phone will boot up now with a fresh installation window - and afterwards you will see a greenish "magisk" symbol on your dock. Just press it and and say "install" - and tadaaa~ there is your root.

    However one important notice is left. OTA won't work from that moment anymore, while magisk is in place (as I wrote in the beginning). However there is a kind of bypass - but currently (for me at least) it wasn't working. So I will get back to it, when I found the solution myself.

    Meanwhile some hints for problems you may encounter if you choose to be stupid, ignore my warning and pressed that shiny "format all" button:

    - You can write back your IMEI with a tool called "Modem Meta v10.2044.0.02" - start it in administrator mode, under settings select the "Disconnect Option" and select the AP DB from stock firmware calibration folder (APDB_MT6853_S01__W2123). Next click connect and restart your phone". Afterwards click in the search tools field and select "IMEI Download". And type it your IMEI for both sim slots (can be found on your phone sticker or on your box, where the phone got delivered in.

    - Should you ever have the issue that the Temperature app is crashing - switch the phone language to "Englisch (United States)" - looks like a error inside the app. Perhaps missing language files?
    - Should the app say "missing calibration data" -> then use SP Flash tool to flash from your backup "ROM_34" to "proinfo" (Should you have fucked up and skipped the backup part.. well.. perhaps somebody else may provide it to you... ask nicely in the forum and I may upload it aswell)

    Then in the end - there might be perhaps some minor mistakes in the guide - but this is my process how "I" did it. Doesn't mean that this is the "best way" - just the way how it worked for me.
    If you have problems or issues or don't understand something - ask nicely and I will respond (most likely).

    And now (hopefully) enjoy your new working rooted Doogee V10! :D Cheers

     


  • @Bartosz Prill Good day, thank you for sharing the above experience, as well as the reported error of the thermometer program. Now the English mode is normal. You can use the thermometer in this language first. This problem has been solved urgently in our research and development, but it needs to be certified by Google, so it will take a while to release the software to solve the problem. It is expected that the certification will be completed next week, and you can use the latest version to use the thermometer. best wishes!


  • @Fragrant X

    "...and you can use the latest version to use the thermometer. best wishes!"

    (Google translator used)

    Hello.

    Has Google certified the solution to the problem with the thermometer in Russian?

    What should I do to fix the problem myself?

     


  • @C-K Good day. It is still undergoing certification. It is expected that the EU version will be able to solve the thermometer error problem through the GOTA upgrade method on October 12th. If you need to use the thermometer now, you can change the system language to English to use the thermometer. Sincere wishes.


  • @Fragrant X 

    ...Thanks for the quick response.

    I will be waiting for the new version for EU.

    How do I know if she is Google certified?

    What will I need to do after this?


  • @C-K Good day, the new version of the European Union can release new software tomorrow, when you connect to the Internet, you can detect the new version and update the version online.


  • @Fragrant X

    ...Hello. Thanks for good news. 


  • @C-K Good day, the latest version of V10 has been pushed in the background, you can check the updated version through Settings-System-System Update


  • @Fragrant X 

    Hello.

    On the forums, they write that many users have received updates.

    For some reason I still don't have it.

    Checking for updates manually doesn't help.

    The internet is working properly.

    Build number: DOOGEE-V10-Android11-20210730

    Serial number: v10eea0000000000009

    What is the problem?


  • @C-K Good day, The mobile phone software version you have is an experience version, not the final mass-produced software, so the latest version cannot be detected. You need to upgrade to the latest software by flashing the machine.

    Flash tool operation is recommended to experienced users only. If you are not yet an experienced flash tool user, please carefully read the flash tool tutorial before proceeding, and strictly follow each instruction.Never format the flash chip of the device

    Software version name:2021-10-11 v100a-dg-m18-mt33-l-1024g48g-hdp-bom1-V10-11.0-20210925_R26多国语量产软件

    Software version link:https://1drv.ms/u/s!AttudHY3VOazgTu7XAwF5xgspL9K?e=25bijH

    Flashing tool link:https://1drv.ms/u/s!AttudHY3VOazgRQZJaDMDQhOtLwn?e=UfGeRU


  • @Fragrant X 

    Good day.

    Thank you for the clarification.


  • Hello Doogee tech support!

    Please make EIS-stabilization in video settings back again. It is disappeared after updates and last update did not help, but EIS was available when i unbox the phone. The camera autofocus is  when the object is close to the camera, so make a macro mode, please. Also the lowest screen brightness is too low, please make a minimal brightneer or correct the light sensor more accurate. Also it will be great if it will be an auto power on\off application. But the main question, when you return EIS?


  • @jove.alex Good day, because this mobile phone platform does not support EIS, this function is removed. Our mobile phone has the function of automatically adjusting the brightness. You can automatically adjust the brightness in the settings-display-automatically adjust the brightness, just turn on the switch.


  • Hello, thnx for fast answer.

    EIS is electronic stabilization and it was perfectly work before update. I dont understand how EIS can be unsupported as it is only software feature. So please try to work on EIS returning. In Doogee tech team we trust!!! Thnx ahead!


  • What about automatic brightness-yes i use automatic brightness, but in the evening V10 brightness automatically adjusts to the minimal-lowest mode. It is too low when on the street is not total dark, the same is in the car and rooms with low lightning. Even when it is total dark at night the lowest degree of automatic brightness is too low. i and my friends cannot see anything, it is real pain for the eyes. I always try to adjust a little manually to make screen brighter. So maybe u can adjust ambient ligh sensor or add settings to add the automatic brightness lowest limit? thnx


  • Hello!
    Unsuccessfully flashed the phone with the flashtool program, by mistake I first made auto format flash. After the firmware, red inscriptions tea key and google key appeared in the upper right corner of the smartphone. I restored the IMEI, now only the red google key inscription remains. How to fix it? Thanks!


  • @Sergey Dobridnev Good day, are you upgrading to which software version, would you tell me your version number?


  • Software version name:2021-10-11 v100a-dg-m18-mt33-l-1024g48g-hdp-bom1-V10-11.0-20210925_R26. S/N V10EEA0000000000559 . My problem appeared after the format flash via flash tool. 


  • 1 / 2
Please login to reply this topic!