DOOGEE V20 new NOEEA software version released DOOGEE-V20-Android11.0-20220323


  • The DOOGEE V20 version is updated as follows:

    NOEEA:A201A68B7.DGE.DOOGEE.HB.HDJ.VFAZPEAEY5VK.20220323.V3.02

    Changelog:
     1. Optimize night vision effect.
     2. Optimize the display problem when powering off and charging.
     3. Optimize the problem of high power consumption when playing MP3 in the file manager.
     
    The phone is connected to the network. The new version can be detected through the Settings app, About Phone - System Updates.
     
    NOEEA FOTA vesion: DOOGEE-V20-Android11.0-20220214 》》》DOOGEE-V20-Android11.0-20220323 
     

    Software version link:https://1drv.ms/u/s!AttudHY3VOazgwVKnHk_a9d9ySMy?e=gZmHCH

    Flash tool operation is recommended to experienced users only. If you are not yet an experienced flash tool user, please carefully read the flash tool tutorial before proceeding, and strictly follow each instruction.

    Except if an authorized or responsible expert directly asked you to do that,
    never format the flash chip of your device or you instantly lose your warranty!

    DOOGEE V20 receives all updates automatically via FOTA method. You need this tool only in case of emergency (if you've bricked your phone), if you want to apply a clean install or if you want to clear all root access and custom recovery to make your phone able to receive FOTA updates again. Moreover, flashing with SPFT is the only option to repair (replace) damaged system software.

    Flashing tool link:https://1drv.ms/u/s!AttudHY3VOazghWnIpBez6rfbngY?e=LsnaCz



  • How do I install this update?


  • @O T good day,The new version can be detected through the Settings app, About Phone - System Updates.


  • hi! I think my V20 is EEA. When will you release the latest update for the EEA version?


  • @O T Our EU software is now certified, and we will release it when the certification is passed.


  • Can the NOEEA be Used to overwrite a EU version (my V20 came as EU and I live in NA)


  • @Geoff MacCombe Good day, you are in North America, it is best to use non-European software. But your current EU software cannot be upgraded to non-European software online, and it needs to be solved by flashing the computer. If you don't know how to flash, use your software first.


Please login to reply this topic!